HDU1701 ACMer【水题】

2021/5/22 10:29:21

本文主要是介绍HDU1701 ACMer【水题】,对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

ACMer
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6539 Accepted Submission(s): 3086

Problem Description
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?

Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.

Output
For each test case, output the minumal number of students in HDU.

Sample Input
1
13.00 14.10

Sample Output
15

Source
2007省赛集训队练习赛(1)

问题链接:HDU1701 ACMer
问题简述:(略)
问题分析:水题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* HDU1701 ACMer */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int t;
    scanf("%d", &t);
    while (t--) {
        double p, q;

        scanf("%lf%lf", &p, &q);

        int ans;
        for (ans = 1; ; ans++)
            if ((int) (p * ans / 100) < (int) (q * ans / 100)) break;

        printf("%d\n", ans);
    }

    return 0;
}


这篇关于HDU1701 ACMer【水题】的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!


扫一扫关注最新编程教程