2021-07-10

2021/7/10 23:37:12

本文主要是介绍2021-07-10,对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

The code provided calculates the largest element of the array nums and outputs it.
Complete the code to declare the nums array and take the array elements as input.
The array can be of any variable size, so the first input should be the size of the array, followed by its elements.

Sample Input
4
12
7
9
34

Sample Output
34

Explanation
The first input number (4) represents the size of the array, the next 4 numbers are the elements. The maximum value is 34.

#include <iostream>
using namespace std;

int main() {
    int n;
    cin>>n; //size of the array
    int *nums= NULL;
    nums=new int[n];
    for(int i=0;i<n;i++){
    	cin>>nums[i];
    }

    int max = nums[0];
    for(int i=0; i<n; i++) {
        if(nums[i]>max)
            max = nums[i];
    }
    cout << max;
    delete[]nums;
    return 0;
}


这篇关于2021-07-10的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!


扫一扫关注最新编程教程