Oil Deposits(dfs)

2021/7/16 23:07:46

本文主要是介绍Oil Deposits(dfs),对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

题目

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output
are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@
@
@@**@
0 0
Sample Output
0
1
2
2
题意分析:
一个图中有许多块油田,边相邻和对角相邻都会合成一个大油田,计算一个图中有多少块油田
解题思路:
遍历找到一块油田之后搜索八个方向是否有相邻的油田,直到没有相邻的油田总由油田数加一

#include<iostream>
#include<cstring> 
using namespace std;

int n,m;
int book[201][201];
char mp[201][201];
void dfs(int x,int y)
{
	int next[9][3]={{1,0},{0,1},{1,1},{-1,0},{0,-1},{1,-1},{-1,1},{-1,-1}};
	for(int i=0; i<8; i++)
	{
		int xx=x+next[i][0];
		int yy=y+next[i][1];
		if(xx>n&&xx<0&&yy>m&&yy<0) continue;
		if(mp[xx][yy]=='@'&&book[xx][yy]!=0)
		{
			book[xx][yy]=0;
			dfs(xx,yy);
		}
	}
}
int main()
{
	
	while(cin>>n>>m)
	{
		if(n==0&&m==0) break;
		int ans=0;
		memset(book,1,sizeof(book));
		memset(mp,'\0',sizeof(mp));
		for(int i=0; i<n; i++)
			for(int j=0; j<m; j++)
				cin>>mp[i][j];
		for(int i=0; i<n; i++)
		{
			for(int j=0; j<m; j++)
			{
				if(mp[i][j]=='@'&&book[i][j]!=0)
				{
					book[i][j]=0;
					dfs(i,j);
					ans++;
					book[i][j]=1;
				}
			 } 
		}
		cout<<ans<<endl;	
	} 
} 



这篇关于Oil Deposits(dfs)的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!


扫一扫关注最新编程教程