PAT Basic 1004 成绩排名

2021/9/3 23:35:53

本文主要是介绍PAT Basic 1004 成绩排名,对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

Problem

读入 \(n\) \((> 0)\) 名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

Input Format

每个测试输入包含 1 个测试用例,格式为

第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩

其中姓名和学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

Output Format

对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。

Sample Input

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

Sample Output

Mike CS991301
Joe Math990112

Solution

#include <iostream>
#include <string>
#include <vector>

using namespace std;

int main() {
    vector<string> name;
    vector<string> id;
    vector<int> score;

    int n;
    cin >> n;

    for (int i = 0; i < n; i++) {
        string currentName;
        string currentID;
        int currentScore;

        cin >> currentName;
        cin >> currentID;
        cin >> currentScore;

        name.push_back(currentName);
        id.push_back(currentID);
        score.push_back(currentScore);
    }

    int minScore = 100;
    int minIndex = 0;
    int maxScore = 0;
    int maxIndex = 0;

    for (int i = 0; i < n; i++) {
        if (score[i] < minScore) {
            minScore = score[i];
            minIndex = i;
        }
        if (score[i] > maxScore) {
            maxScore = score[i];
            maxIndex = i;
        }
    }

    cout << name[maxIndex] << " " << id[maxIndex] << endl;
    cout << name[minIndex] << " " << id[minIndex] << endl;

    return 0;
}


这篇关于PAT Basic 1004 成绩排名的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!


扫一扫关注最新编程教程