逆序对计数问题

2021/9/21 6:27:21

本文主要是介绍逆序对计数问题,对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

7-4 求逆序对数目 (20 分)  

注意:本问题算法的时间复杂度要求为O(nlogn), 否则得分无效

题目来源:http://poj.org/problem?id=1804 Background Raymond Babbitt drives his brother Charlie mad. Recently Raymond counted 246 toothpicks spilled all over the floor in an instant just by glancing at them. And he can even count Poker cards. Charlie would love to be able to do cool things like that, too. He wants to beat his brother in a similar task.

Problem Here's what Charlie thinks of. Imagine you get a sequence of N numbers. The goal is to move the numbers around so that at the end the sequence is ordered. The only operation allowed is to swap two adjacent numbers. Let us try an example: Start with: 2 8 0 3 swap (2 8) 8 2 0 3 swap (2 0) 8 0 2 3 swap (2 3) 8 0 3 2 swap (8 0) 0 8 3 2 swap (8 3) 0 3 8 2 swap (8 2) 0 3 2 8 swap (3 2) 0 2 3 8 swap (3 8) 0 2 8 3 swap (8 3) 0 2 3 8

So the sequence (2 8 0 3) can be sorted with nine swaps of adjacent numbers. However, it is even possible to sort it with three such swaps: Start with: 2 8 0 3 swap (8 0) 2 0 8 3 swap (2 0) 0 2 8 3 swap (8 3) 0 2 3 8

The question is: What is the minimum number of swaps of adjacent numbers to sort a given sequence?Since Charlie does not have Raymond's mental capabilities, he decides to cheat. Here is where you come into play. He asks you to write a computer program for him that answers the question in O(nlogn). Rest assured he will pay a very good prize for it.

输入格式:

The first line contains the length N (1 <= N <= 1000) of the sequence; The second line contains the N elements of the sequence (each element is an integer in [-1000000, 1000000]). All numbers in this line are separated by single blanks.

输出格式:

Print a single line containing the minimal number of swaps of adjacent numbers that are necessary to sort the given sequence.

输入样例:

在这里给出一组输入。例如:

6
-42 23 6 28 -100 65537

输出样例:

在这里给出相应的输出。例如:

5

 

解题思路:运用冒泡排序,通过两两交换,再加一个计数器,要注意如果没有发生交换就不会执行下一趟排序,也就不会计数。

冒泡排序:

for(int j=0;j<m;j++){
  if(list[j]>list[j+1]){
    t = list[j];
    list[j]=list[j+1];
    list[j+1]=t;
  }
}

代码:

 

import java.util.Scanner;

public class Java2_4 {
  public static void main(String[] args){
    Scanner input = new Scanner(System.in);
    int N = input.nextInt();
    int[] list = new int[N];
    for(int i = 0;i<N;i++){
      list[i] = input.nextInt();
    }
    int m=list.length-1;     //
    int flag = 1;
    int t;
    int num=0;
    while((m>0)&&(flag==1)){       //注意判断条件,表示将最大值放到末尾的趟数。如果只剩一个,而其他的数都放到了末尾,那么这个数就没有必要进行比较,因此 -1。
      flag =0;                     //先把flag置为0,如果没有发生交换就不会执行下一趟排序
      for(int j=0;j<m;j++){
        if(list[j]>list[j+1]){
          flag = 1;                //执行一次排序flag就会变为1,进行下一次排序
          t = list[j];
          list[j]=list[j+1];
          list[j+1]=t;
          num++;
        }
      }
      --m;
    }
    System.out.print(num);
  }
}

 




这篇关于逆序对计数问题的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!


扫一扫关注最新编程教程