Digital Roots

2021/10/4 23:40:50

本文主要是介绍Digital Roots,对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0

Sample Output

6
3

思路:

暴力递归!

但是要注意一个细节,不能直接使用数进行操作,会越界,建议使用字符串来得到第一个数字,然后放到递归函数里去!

代码:

#include<stdio.h>
#include<string.h>
int dfs(int n){//构建一个递归函数
	int b = 0;
	while(n>0){
		b = b + (n%10);
		n = n /10;
	}
	if(b>9) return dfs(b);
	else printf("%d\n",b); 
}
int main()
{
	int i=0,j,k;
	char ch[10010];
	while(scanf("%s",&ch)!=EOF)
	{
		k = strlen(ch);
		if(ch[0]=='0') break;
		else{
			for(j=0;j<k;j++){//用字符来输入!!!
				i += ch[j] - '0';
			}
		}
		dfs(i);
		i=0;//注意归0
	 } 
	 return 0;
}



这篇关于Digital Roots的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!


扫一扫关注最新编程教程