POJ1984 Navigation Nightmare

2022/7/11 6:20:21

本文主要是介绍POJ1984 Navigation Nightmare,对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

题目链接

题目

Description

Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n):

           F1 --- (13) ---- F6 --- (9) ----- F3
            |                                 |
           (3)                                |
            |                                (7)
           F4 --- (20) -------- F2            |
            |                                 |
           (2)                               F5
            | 
           F7 

Being an ASCII diagram, it is not precisely to scale, of course.

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path
(sequence of roads) links every pair of farms.

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road:

There is a road of length 10 running north from Farm #23 to Farm #17
There is a road of length 7 running east from Farm #1 to Farm #17
...

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob:

What is the Manhattan distance between farms #1 and #23?

FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms.
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points).

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with "-1".

Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2..M+1: Each line contains four space-separated entities, F1,
    F2, L, and D that describe a road. F1 and F2 are numbers of
    two farms connected by a road, L is its length, and D is a
    character that is either 'N', 'E', 'S', or 'W' giving the
    direction of the road from F1 to F2.

  • Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's
    queries

  • Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob
    and contains three space-separated integers: F1, F2, and I. F1
    and F2 are numbers of the two farms in the query and I is the
    index (1 <= I <= M) in the data after which Bob asks the
    query. Data index 1 is on line 2 of the input data, and so on.

Output

  • Lines 1..K: One integer per line, the response to each of Bob's
    queries. Each line should contain either a distance
    measurement or -1, if it is impossible to determine the
    appropriate distance.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6

Sample Output

13
-1
10

Hint

At time 1, FJ knows the distance between 1 and 6 is 13.
At time 3, the distance between 1 and 4 is still unknown.
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10.

Source

USACO 2004 February

题解

知识点:并查集。

显然用带权并查集维护子节点到根节点的坐标变化。

考虑用 \(x\) 代表东西方向位移 ,\(y\) 代表南北方向位移,取北和东为正方向。

压缩路径和合并都可以向量理解:

压缩路径,\(\vec{ar} = \vec{ab} + \vec{br}\) ,其中 \(a\) 是待压缩节点,\(b\) 是父节点,\(r\) 是根节点。

合并集合,\(\vec{AB} = -\vec{aA} + \vec{ab} + \vec{bB}\) ,\(a\) 和 \(b\) 是条件给出节点,\(A\) 和 \(B\) 是条件节点所在集合的根节点,目的是把 \(A\) 合并到 \(B\)。

输入输出极度复杂,需要先保存信息,再离线处理,在每个时间点记录答案,最后输出。

时间复杂度 \(O(n + m\log n + k\log k)\)

空间复杂度 \(O(n+m+k)\)

代码

#include <iostream>
#include <algorithm>

using namespace std;

struct node {
    int x, y;
}v[40007];
int fa[40007];
struct Info1 {
    int f1, f2, l;
    char d;
}in1[40007];
struct Info2 {
    int f1, f2, t, id;
}in2[40007];
int ans[40007];

int find(int x) {
    if (fa[x] == x) return x;
    int pre = fa[x];
    fa[x] = find(fa[x]);
    v[x].x += v[pre].x;
    v[x].y += v[pre].y;
    return fa[x];
}

bool cmp(Info2 a, Info2 b) { return a.t < b.t; }

int main() {
    std::ios::sync_with_stdio(0), cin.tie(0), cout.tie(0);
    int n, m;
    cin >> n >> m;
    for (int i = 1;i <= n;i++) fa[i] = i;
    for (int i = 1;i <= m;i++) {
        cin >> in1[i].f1 >> in1[i].f2 >> in1[i].l >> in1[i].d;
    }
    int k;
    cin >> k;
    for (int i = 1;i <= k;i++) {
        cin >> in2[i].f1 >> in2[i].f2 >> in2[i].t;
        in2[i].id = i;
    }
    sort(in2 + 1, in2 + 1 + k, cmp);
    for (int t = 1, pos = 1;t <= m;t++) {
        int r1 = find(in1[t].f1);
        int r2 = find(in1[t].f2);
        if (in1[t].d == 'N' || in1[t].d == 'S') {
            int y;
            if (in1[t].d == 'N') y = in1[t].l;
            else if (in1[t].d == 'S') y = -in1[t].l;
            v[r1].x = -v[in1[t].f1].x + v[in1[t].f2].x;
            v[r1].y = -v[in1[t].f1].y + y + v[in1[t].f2].y;

        }
        if (in1[t].d == 'E' || in1[t].d == 'W') {
            int x;
            if (in1[t].d == 'E') x = in1[t].l;
            else if (in1[t].d == 'W') x = -in1[t].l;
            v[r1].x = -v[in1[t].f1].x + x + v[in1[t].f2].x;
            v[r1].y = -v[in1[t].f1].y + v[in1[t].f2].y;
        }
        fa[r1] = r2;
        while (t == in2[pos].t) {
            if (find(in2[pos].f1) == find(in2[pos].f2)) {
                ans[in2[pos].id] = abs(v[in2[pos].f1].x - v[in2[pos].f2].x) + abs(v[in2[pos].f1].y - v[in2[pos].f2].y);
            }
            else ans[in2[pos].id] = -1;
            pos++;
        }
    }
    for (int i = 1;i <= k;i++) cout << ans[i] << '\n';
    return 0;
}


这篇关于POJ1984 Navigation Nightmare的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!


扫一扫关注最新编程教程