PAT Advanced 1027 Colors in Mars(20)

2022/8/21 6:56:34

本文主要是介绍PAT Advanced 1027 Colors in Mars(20),对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

题目描述:

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

算法描述:进制转换 模拟

题目大意:

输入三个十进制数,转换十三进制输出

#include<iostream>
using namespace std;

char str[14]="0123456789ABC";
int main()
{
    cout << "#";
    for(int i = 0; i < 3 ; i++)
    {
        int num;
        cin >> num;
        cout << str[num / 13] << str[num % 13];
    }
    return 0;
}


这篇关于PAT Advanced 1027 Colors in Mars(20)的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!


扫一扫关注最新编程教程