每日一淦2021.8.24

2021/8/24 23:11:43

本文主要是介绍每日一淦2021.8.24,对大家解决编程问题具有一定的参考价值,需要的程序猿们随着小编来一起学习吧!

ALDS1_1_D 在时间线上的最大利润。

Maximum Profit

You can obtain profits from foreign exchange margin transactions. For example, if you buy 1000 dollar at a rate of 100 yen per dollar, and sell them at a rate of 108 yen per dollar, you can obtain (108 - 100) × 1000 = 8000 yen.

Write a program which reads values of a currency $R_t$ at a certain time $t$ ($t = 0, 1, 2, ... n-1$), and reports the maximum value of $R_j - R_i$ where $j > i$ .

Input

The first line contains an integer $n$. In the following $n$ lines, $R_t$ ($t = 0, 1, 2, ... n-1$) are given in order.

Output

Print the maximum value in a line.

Constraints

  • $2 \leq n \leq 200,000$
  • $1 \leq R_t \leq 10^9$

Sample Input 1

6
5
3
1
3
4
3

Sample Output 1

3

Sample Input 2

3
4
3
2

Sample Output 2

-1

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main() {
int n,a[200000];
cin >> n;
for (int i = 0;i < n; i++)
cin >> a[i];
int min1 = a[0];
int max1 = -1000000000;
for (int i = 1; i < n; i++) {
max1 = max(max1, a[i] - min1);                 //max()和min()函数需要头文件带<algorithm>才能使用。
min1 = min(min1, a[i]);
}
cout << max1 << endl;
return 0;
}



这篇关于每日一淦2021.8.24的文章就介绍到这儿,希望我们推荐的文章对大家有所帮助,也希望大家多多支持为之网!


扫一扫关注最新编程教程